X4M300+EX4C01 MODULE

Discussion in 'Presence Sensor' started by Valentina, Aug 8, 2019.

  1. Valentina

    Valentina New Member

    Hi,
    I have a problem with the wifi module.
    I have connected the wifi module with the X4M300 sensor, then I entered the settings suggested by Exceed EX4C01 User Manual.
    The problem is that I can't read the data sent by the sensor.
    I tried to create a tcp service to verify the packages but I received nothing.
    Is there any other procedure to follow?
    Attached the settings images.
    Thanks for any suggestions.

    [​IMG][​IMG][​IMG][​IMG]
     
  2. Charlie Shao

    Charlie Shao Moderator Staff Member

    Hi Valentina,
    ModuleConnecter has support for access to TCP server(Exceed EX4C01 and so on), you can just replace serial port with TCP address like "-d tcp://192.168.1.169:3000". You can use this example directly.
     
  3. Valentina

    Valentina New Member

    thank you Charlie for the prompt reply.
    1. If I use the module x4m300, is it ok in the settings if I set the socket type as TCP server ? WhatsApp Image 2019-08-09 at 11.39.14.jpeg

    2. once connected with the wifi module, I can't see the x4m300 in the xethru explorer. Is it normal?

    3. I tried to run your example setting the TCP address instead of the port but I receive this error.
    WhatsApp Image 2019-08-09 at 12.11.33.jpeg

    which tcp address and port I have to insert in the command?
     
  4. Charlie Shao

    Charlie Shao Moderator Staff Member

    Hi Valentina,

    1) It is correct.
    2) XE does not support TCPIP connection yet, so it is normal.
    2) Is the TCP server IP address correct or in the same local network? Try to ping this address to check if it is on the same network.