Using module connector on mac

Discussion in 'Module Connector (MC)' started by Nir Regev, Dec 2, 2017.

  1. Nir Regev

    Nir Regev New Member

    Hi,

    I am trying to run one of the python examples in your module connector.

    I am using a new macbook pro with only USB-C connector. The radar led lights up blinking blue, but I get the following error when I try to run an example called:
    regmap_example.py

    I run like this
    > python3 regmap_example.py
    Traceback (most recent call last):

    File "regmap_example.py", line 33, in <module>

    sys.exit(main())

    File "regmap_example.py", line 19, in main

    mc = ModuleConnector(module[0])

    IndexError: list index out of range


    I also tried the xethru explorer for Mac and it doesn't recognize the device, attached is a screen shot of what I am getting

    let me know how to solve this ASAP.

    Thanks 2017-12-01 at 5.11 PM.jpeg
     
  2. Charlie Shao

    Charlie Shao Moderator Staff Member

    Hi Nir,
    Sorry for the delay, I tested on several OSX devices, found the same problem on one Mac mini. The problem is caused by serial port cannot be recognized. We may need more time to debug this problem. I will feedback to you as soon as possible.
     
  3. Nir Regev

    Nir Regev New Member

    any feedback on this?
     
  4. Charlie Shao

    Charlie Shao Moderator Staff Member

    Hi Nir,
    Sorry, but there is no better solution for now. I have requested for high priority for this problem. Hope to release a fix soon.
     
    CCB likes this.
  5. Charlie Shao

    Charlie Shao Moderator Staff Member

    Hi Nir,
    The Mac Mini which has the same problem is running OS X/macOS 10.10.5 (Yosemite). We have not been able to reproduce on 10.13 (High Sierra). Apple appears to have made rather big changes in their USB driver structure in 10.11 (El Capitan), so a hypothesis is that our USB implementation has some compatibility issues with the older macOS USB CDC driver.
    Could you check the version of your macOS?