time to detect presence/non presence

Discussion in 'Presence Sensor' started by ignacio pedreira, Jul 30, 2018.

  1. ignacio pedreira

    ignacio pedreira New Member

    Hello

    Im testing a X4M300 sensor and once the sensor detects presence (few seconds) i go out of sensor range and it last one minute or more to come back to "non presence" status. In your videos this time seems to be about seconds and not a minute.

    How can we reduce the time need to roll back to non "presence status" once the user left the radar area??? One minute seems to much for our application.

    Thank you!
     
  2. Aksel Johnsby

    Aksel Johnsby Moderator Staff Member

  3. ignacio pedreira

    ignacio pedreira New Member

    Thank you!!

    Can you update this to use with a X4M300 ?

    Regards
     
  4. ignacio pedreira

    ignacio pedreira New Member

    Im trying to update it but getting errors when running.

    Shape mismatch: objects cannot be broadcast to a single shape
     

    Attached Files:

  5. Aksel Johnsby

    Aksel Johnsby Moderator Staff Member

    Sure, here you go :)

    Have a great day!
    --
    Aksel
     

    Attached Files:

  6. ignacio pedreira

    ignacio pedreira New Member

  7. Steffen

    Steffen New Member

    Hi Aksel,

    Do I need the X4M03 Development Kit to use the python code or can I use the X4M300 presence sensor?
    It would be helpful to me, if you explain in short steps which hardware and software components are used?

    Many thanks!
     
  8. Aksel Johnsby

    Aksel Johnsby Moderator Staff Member

    Hi Steffen,

    You need the X4M200 firmware to run the example from https://www.xethru.com/community/threads/fast-state-detection.391/#post-1799. But as you can see I rewrote the example to be compatible with X4M300.

    To summarize:
    The example are running on a profile level i.e. X4M300 & X4M200. X4M03 does not contain any profile, just XEP. Moduleconnector is the software needed to run this example.

    Have a great day!
    --
    Aksel