Stuck in Bootloader mood

Discussion in 'Respiration Sensor' started by Olle Alm, Dec 16, 2016.

  1. Olle Alm

    Olle Alm New Member

    Hi!
    I've been playing around with the X2M200 and arduino a bit and got it running nicely first using the "xethru_resperation_led" from the resources and then my own setup in "breathing mode" just using IO1-4.
    But after trying to go back to "full mode" (with the xethru_resperation_led) the X2M200 is stuck in *Bootloader mood" with the LED turned blue.
    When connecting to the XeThruExplorer (2.2.12 OSX) it tries to upgrade the firmware but fails.
    (see attached images)

    Anyone got any idea how to resolve this or do you think it even might be broken?

    Glad for any suggestions or ideas.
    Thank you!
    Olle
     

    Attached Files:

    • 1.png
      1.png
      File size:
      76.9 KB
      Views:
      26
    • 2.png
      2.png
      File size:
      90.4 KB
      Views:
      24
    • 3.png
      3.png
      File size:
      69.8 KB
      Views:
      24
  2. marcoyip

    marcoyip New Member

    sorry, can you tell me how to connect x2m200 to arduino?
    i dont know it because it just had x2m1000 tutorial.
     
  3. Olav Liseth

    Olav Liseth Administrator Staff Member

  4. Olle Alm

    Olle Alm New Member

    Thank you for your reply!

    No, I get the same result if I'm connecting with just the USB to the computer and no other pins connected.
    (Or pin 3 (rx) to tx on the Arduino)

    It could though have been the reason I first got stuck in bootloader, I'm getting a bit unsure exactly how it was connected then.

    I been looking into the nRESET mode mentioned in the data sheet (p.16-17) but a bit unsure how it works and if it would possibly help me.
     
  5. Olle Alm

    Olle Alm New Member

    Problem solved.
    By using the XeThruExplorer for Windows instead of OSX the the firmware upgrade was successful and it now works on the Mac as well.
     
  6. sundus

    sundus New Member

    Hi
    I am also facing this problem. I am using XeThruExplorer for Windows but the firmware upgrade failed. Please suggest me its solution.
     
  7. Olav Liseth

    Olav Liseth Administrator Staff Member

    Hi sundus,

    Can you confirm that you are using X2M200 with latest XeThru Explorer version? Have you used other connectors than usb? Can you try from a windows 10 pc?
     
  8. sundus

    sundus New Member

    Hi Olav
    Thank you for your kind response.
    Yes I'm using latest version of XethruExplorer.
    I've connected it serially with ardinuo mega board and successfully run distance tracking example code. Then on connecting it with usb I got firmware problem.
    I've not tried on windows 10 PC yet. Let me try this.
     
  9. sundus

    sundus New Member

    Hi Olav
    Thank you for your suggestion. Connecting this sensor module with Windows 10 PC solved this problem.
     
    Olav Liseth likes this.
  10. vikas mehra

    vikas mehra New Member

    Hi Sundus

    I have seen your post. Good Job done.
    You mentioned that you are able to connect X2M200 with arudino Mega successfully (Dist. Tracking)
    Could you please mention How?

    1. Have you used same example code as given "https://github.com/oyvdahl/xethru-a...istance-sensor/zero-radar-distance-sensor.ino" ?

    2. Did you made some changes in code to connect with Arudino Mega as code mentioned above is to connect with Arudino Zero?

    Please reply. Any other suggestions are most welcome.

    Thanks & Regds
    Vikas Mehra
     
  11. Robert Chichester

    Robert Chichester New Member

    We are having frequent but random problems wherein we initiate a firmware update using the MCP wrapper in a linux environment and the process seems to hang up...that is, not complete. We have to then run a special application that immediately calls mcpw_firmware_upgrade() which then completes the process. This suggests that the X4M200 gets stuck in bootloader mode and somehow gets out of sequence when uploading the new firmware. So my questions are:
    • Is this a known behavior?
    • Is there a fix or a workaround to this?
    • On a related note, is there a way to detect that the X4M200 is in bootloader mode using the MCP wrapper?
    This has been a recurring problem for us and it is difficult to solve because it is rather random.