[Solved] [Python] Unable to run XEP_X4M200_X4M300_plot_record_playback_radar_raw_data

Discussion in 'Presence Sensor' started by Spiderixius, Jan 31, 2019.

  1. Spiderixius

    Spiderixius New Member

    Hello

    I am unable to run the XEP_X4M200_X4M300_plot_record_playback_radar_raw_data.py file which comes with the ModuleConnector examples (https://www.xethru.com/community/resources/module-connector-windows.78/)

    I ran the following way:

    python XEP_X4M200_X4M300_plot_record_playback_radar_raw_data.py -f data\xethru_recording_meta.dat

    It simply responds with this:

    Starting playback for data\xethru_recording_meta.dat
    Duration(ms): 317065


    I also tried running it as such:
    python XEP_X4M200_X4M300_plot_record_playback_radar_raw_data.py -d COM3

    and get the following error: https://hastebin.com/ubeyaheret.rb
     
  2. Spiderixius

    Spiderixius New Member

  3. Charlie Shao

    Charlie Shao Moderator Staff Member

  4. Spiderixius

    Spiderixius New Member

    Hey. I have updated the firmware. The error also happens on the latest example on Github, however if I try to run it a couple of times it suddenly works. I will make a separate thread for that since I have some other questions related to that script. Thank you very much for the fast response Charlie Shao.
     
  5. Spiderixius

    Spiderixius New Member

    So, for whatever reason rerunning the script solves the problem. The problem happens sometimes but I am not sure what triggers it. I have a theory that if the sensor is running in Xethru Explorer then the script does not work.
     
  6. Charlie Shao

    Charlie Shao Moderator Staff Member

    Yes, the sensor can only communicate with one host at one time. When it is connected with XE, the serial port is occupied, so the script will not work.
     
    Spiderixius likes this.
  7. Spiderixius

    Spiderixius New Member

    Ah, that makes sense. Thanks Charlie Shao.