Sensor not detected on Windows 7

Discussion in 'XeThru Explorer' started by Øyvind Nydal Dahl, Jun 2, 2015.

  1. Øyvind Nydal Dahl

    Øyvind Nydal Dahl New Member

    I just installed the XeThru Explorer software on windows 7. The text looks a bit weird (fuzzy), but anyway -- it just says: "Please connect your XeThru sensor device".

    I have connected the sensor and it's being detected by Windows as USB to UART device.

    Am I missing something essential? The sensors came preloaded with firmware right?

    It might be my windows also, I'm having lots of trouble with it. Going to switch to Linux now and see if I can get some communication going directly with the serial port.

    Update: I can communicate with the sensor directly through the serial port, so must be a SW problem..
    Last edited: Jun 2, 2015
  2. admin

    admin Administrator Staff Member

    Do you get the same issue when connecting the kit to the USB before firing up XeThru Explorer?
  3. Øyvind Nydal Dahl

    Øyvind Nydal Dahl New Member

    Yes, same thing. I'll add a screenshot here. As you can see, the text is a bit weird. Not sure if that has anything to do with it, but I'll add it anyway:

    screenshot.png .
  4. Olav Liseth

    Olav Liseth Administrator Staff Member

    It should be listed as "USB Serial Port (COMn)", where n is a number, under ports (COM & LPT) in Device Manager (start -> devmgmt.msc).

    Can you right click on the device, click uninstall, check "Delete the driver software for this device", replug the device. If this do not work, try to install the drivers manually, you can download the latest version here:
  5. Øyvind Nydal Dahl

    Øyvind Nydal Dahl New Member

    I will try that and get report back.
  6. Øyvind Nydal Dahl

    Øyvind Nydal Dahl New Member

    Ok, reinstalling the drivers did the trick!
    Olav Liseth likes this.
  7. Luke

    Luke New Member

    hallo Sir,

    Some troubles happened with my boards delivered today:
    My board is not detected by Windows 7 as USB to UART device after I connect the sensor to 3 different PCs.

    Also, XeThru Explorer shows "Please connect your XeThru sensor device" when connected the board.

    I have tried to install SW below:
    -XeThruExplorer-win32-2.1.1-beta from XeThru
    -driver-atmel-bundle-7.0.888.exe from XeThru
    -CDM21224_Setup.exe from

    Please, gentlemen, help me to identify the root cause and fix them. Many thanks!!!
  8. Olav Liseth

    Olav Liseth Administrator Staff Member

    Hi Luke,

    The above discussion was about the previous X2M1001 sensor. I assume you have the X2M200 sensor, thus the FTDI driver is not relevant.
    I have not seen similar behavior before, can you please try to:

    1. Reinstall atmel driver bundle
    2. Restart computer
    3. Open device manager and connect X2M200
    a. Is device manager window updated after plugging in the sensor?
    b. Is the sensor LED blinking?
    4. Have you installed other drivers that overrides the atmel driver?

    Windows 7 has some driver issues, this is fixed in Windows 10.
  9. Dhani Dharmaprani

    Dhani Dharmaprani New Member

    Hi Olav,

    I am having the same problem as Luke above (on a Windows 7 machine) and have followed the steps you listed, all to no avail. Do you perhaps know how I can fix this issue?

    Thank you kindly in advance!
  10. Luke

    Luke New Member

    Hello Olav,

    Still, it didn't work.

    Again, I tried X2M200 on two Win7 64bit PC and one Win10 64bit PC. After connected, no hardware detected by device manger and XeThru Explorer showed "Please connect your XeThru sensor device" . LED1 flashed as green 12-13/minute.

    It make me freak out to suck in power-up step :oops:
  11. Hi,
    Have you tried different USB cables? The quality can vary a lot.
  12. Luke

    Luke New Member

    Hi Marius,

    I will try on diversified USB cables and feed back to you asap.
  13. Luke

    Luke New Member

    Dear Marius,

    a. My X2M200 was send out Nov. 3 and received Nov. 7. The serial number is 100000003100.

    b. I have tried and failed with three kinds of higher quality USB cable.
  14. Evan Cloney

    Evan Cloney New Member

    Hi All,

    I also had the same issue above with the X2M200 not being recognized by my laptop running windows 7. I did all the steps above which didn't fix the issue. In the end it turned out to be the cable that fixed it had to try four different cables before I got one to work.
    Hope this helps.
    Olav Liseth likes this.
  15. TamirM

    TamirM New Member


    Had the same problem described above with X4M300.
    Can you please attach the link for the right driver? Win 7 , 64 bit.

  16. Charlie Shao

    Charlie Shao Moderator Staff Member

    Here is the link:
  17. eduemon

    eduemon New Member

    dear @Charlie Shao . i have X4M300 and i got problem when i connected the sensor to my laptop (window 7, 64 bit). the sensor could not been detected by my laptop. i have downloaded the latest xethru explorer, installed the XE and also the driver inside the zip file, but still the sensor has not been recognized by my laptop. do you have solution for that?
  18. Charlie Shao

    Charlie Shao Moderator Staff Member

    Have you tried this driver We found the driver inside the XeThru zip file may not work in some condition.
  19. eduemon

    eduemon New Member

    thank you for your response. I did try to install the driver you gave (BOSSA) without connecting the device with my laptop. I did not get any changes and my laptop still cannot recognize the sensor. However, i tried the device on my friend laptop with Windows 10 and it works without any problem. But, i still curious why it could not be recognized in my windows 7 laptop.