Module Connector unix V1.4.2 times out under a ubuntu VM

Discussion in 'Module Connector (MC)' started by Britto Martial, Oct 2, 2017.

  1. Britto Martial

    Britto Martial New Member

    Hi,

    i have been trying to connect xethru x4 to a VM where its being recognized as ttyACM0 but the communication times out when a reset is provided to it. Please provide any insights if you have.

    Below is the error
    Exception in thread radarThreadX4:
    Traceback (most recent call last):
    File "/home/ubuntu/anaconda2/envs/pyqt27_4/lib/python2.7/threading.py", line 801, in __bootstrap_inner
    self.run()
    File "/home/ubuntu/Downloads/V11_1_6/V11_1 _6_X4_MTI_Filt/radarHandler.py", line 172, in run
    self.reset(self.radarPort)
    File "/home/ubuntu/Downloads/V11_1_6/V11_1 _6_X4_MTI_Filt/radarHandler.py", line 206, in reset
    r.module_reset()
    File "/home/ubuntu/anaconda2/envs/pyqt27_4/lib/python2.7/site-packages/pymoduleconnector-1.2.2-py2.7.egg/pymoduleconnector/moduleconnectorwrapper/__init__.py", line 4529, in module_reset
    return _moduleconnectorwrapper.PyXEP_module_reset(self)
    RuntimeError: Timeout waiting for response

    Its the same with Module connector 1.4.2

    Thanks,
    britto
     
  2. Marius Lind Volstad

    Marius Lind Volstad Member Staff Member

    Hi,
    I don't have any immediate insights, but I have some followup questions:
    Have you tried any other commands than module_reset()? What happens when you try e.g. ping()?
    What VM are you using and what is the host system?
    Are you using USB or UART communication with the X4 module? In case of USB, what is the output of "lsusb -l"?
    Best regards,
    Marius
     
  3. Britto Martial

    Britto Martial New Member

    Hi Marius,

    No I used just module_reset(), but will try ping() and add the behaviour
    My host machine is Windows 10, with Ubuntu 16.04 VM running on an Oracle VM Virtualbox
    I tried using dmesg, which displayed the xethru radar as "ttyACM0"

    Thanks,
    Britto