Crash on Windows 10

Discussion in 'XeThru Explorer' started by Davide Bongiovanni, Feb 1, 2017.

  1. Davide Bongiovanni

    Davide Bongiovanni New Member

    Hello,

    I tried to run the XeThru explorer on my Windows 10 machine and as soon as I press either button for selecting the profile (Respiration or Sleep) the program crashes. Once it even crashed before showing anything. I would like to point out that I installed all the required drivers.

    Am I missing some steps or is it the program's fault?
     
  2. Olav Liseth

    Olav Liseth Administrator Staff Member

    Hi Davide,

    Sounds correct. Your module were thoroughly tested after production, so something is still probably wrong on your computer. Could you please check:

    1. Driver name, can be found in Windows' device manager - > Ports
    2. LED color/behavior during connection
    3. Test from another computer
    4. Describe how XeThru Explorer crashes, do you get any error message?

    Olav
     
  3. Davide Bongiovanni

    Davide Bongiovanni New Member

    1. I installed the drivers provided in the zipped folder that I downloaded from your website. I tested the software both before and after installing them. It does not work either way. The name seems to be Communication Device Class ASF example, provided by ATMEL inc.

    2. LED behaviour: connect device: green -> yellow -> red. Open application: green -> yellow -> red -> yellow, cycling. Select RESP/SLEEP: freezes on whatever color was during the previous step.

    3. It was tested on a MacBook Pro and a Windows 7 computer and it worked on both of them.

    4. The crash is the usual Windows "XeThruExplorer.exe has stopped working"

    Thank you for your time.

    Davide

    EDIT: By looking in the Windows Event Viewer, I could find that the faulty module is the DLL by the name of ig4icd32.dll. After some googling, it appears that Windows 10 has some issue with said DLL. I will do some more research.
     
    Last edited: Feb 2, 2017
  4. Davide Bongiovanni

    Davide Bongiovanni New Member

    I think I might be on the right track. It appears that the XeThru explorer applications tries to open ig4icd32.dll in the path %SystemRoot%\System32\ig4icd32.dll, but looking into that folder, I could only see ig4icd64.dll

    EDIT: Although, downloading it from the internet and placing it there didn't work :(
     
    Last edited: Feb 7, 2017
  5. Bjørn Erik Nilsen

    Bjørn Erik Nilsen New Member

    Hi Davide,

    I think this issue is related to a bug in the Qt framework used by XeThruExplorer. More specifically it looks like an issue related to your Intel graphics card. We will address this in the next release of XeThruExplorer. In the meantime you can try to set environment variable QT_OPENGL=angle as a workaround.

    Hope this helps.
     
  6. Davide Bongiovanni

    Davide Bongiovanni New Member

    Yes, this helped. Thank you.
     
  7. NSANGOU CHOUAIBOU

    NSANGOU CHOUAIBOU Active Member

    Hi,
    I've just buy presence sensor and respiration sensor. I used the latest version on XeThru Explorer (XeThruExplorer-win32-2.3) on windows 10 and it works like a charm !
    Good job guys keep it up !
    BR.