Corrupt signal data for particular frame offset/start/end values

Discussion in 'Module Connector (MC)' started by Alex Pitt, Feb 27, 2018.

  1. Alex Pitt

    Alex Pitt New Member

    Hi there,

    I am currently writing some custom software to acquire raw radar signal data from an X4M02. The python scripts, module connector code, XEP code and documentation were used as references to implement the Xethru serial communication protocol.

    This software has worked well, except when customizing frame-offset and frame-area values. Particular configurations of these values seems to result in corrupted signal data: large sections of the signal take on values far outside the normalized [-1.0, 1.0] range.

    For context, we use the following initialization message sequence:

    reset module (wait 3 seconds)
    ping (wait for pong)
    set mode to stop (wait for ack)
    set mode to manual (wait for ack)
    init x4 driver (wait for ack)
    set-downconversion to 0 (wait for ack)
    set pulses-per-step to 300 (wait for ack)
    set iterations to 16 (wait for ack)
    set dac-min to 949 (wait for ack)
    set dac-max to 1100 (wait for ack)
    set frame-offset to <X> (wait for ack)
    set frame-area-start to <Y> (wait for ack)
    set frame-area-end to <Z> (wait for ack)
    set fps to 17 (wait for ack)

    Some combinations of X/Y/Z produce good signal data, others don't. I did some quick trial-and-error to narrow down the parameter interval where signal data transitions from good to corrupted:

    frame-offset(m), frame-start(m), frame-end(m), signal(good/bad)
    0.0, 0.0, 2.9, bad
    0.0 0.0, 3.0, good
    0.0 0.0, 4.006, good
    0.0 0.0, 4.005, bad
    0.0 0.0, 7.39, bad
    0.0 0.0, 7.4, good

    Is there something obvious I could be missing? If not, then could someone confirm/deny that these parameter combinations all produce normal signal data?

    I have tried different X4M02 modules, and X4M03 modules and initialisation sequences, and tried to dump all PIF registers and see if there are any obvious differences between good and bad configurations, but to no avail.

    Cheers,
    Alex
     
  2. Charlie Shao

    Charlie Shao Moderator Staff Member

    Hi Alex,
    We have fixed a bug regarding set frame area that affected the RF data for certain start/stop setting. Your problem sounds similar. Make sure your X4M02(X4M200/X4M300) has the latest version of firmware. You can update firmware by connecting module to the lastest XeThru Explorer. It will check the firmware version and update it. Let's see what will happen when it has the lastest XEP.
     
  3. Alex Pitt

    Alex Pitt New Member

    Hi Charlie,

    Thanks for your reply. It does seem like the latest firmware fixes this problem. I thought I was using the latest firmware, but I was working on a machine using XethruExplorer one version behind (oops!).

    Cheers,
    Alex