Can't get XeThru Explorer to work on macOS Sierra

Discussion in 'XeThru Explorer' started by lynx, Oct 24, 2016.

  1. lynx

    lynx New Member


    I cannot get the X2M200 to work: I installed version 2.1.1-beta of XeThru Explorer for Mac OS on my macOs Sierra 10.12. I connected the sensor with USB. Nothing, “Please connect your XeThru sensor …” message in the app. I tried installing the driver from here:, restart, reconnect, still not working. The device itself is blinking green but does not appear in System Information.

    I would appreciate any help.

    Thanks and kind regards,
  2. lynx

    lynx New Member

    Update: Reproduced the same issue on another device running macOS Sierra. Did not test with the extra driver installed.
  3. Bjørn Erik Nilsen

    Bjørn Erik Nilsen New Member


    I just upgraded to macOS Sierra and have no problems running XeThruExplorer with the device connected to USB. You shouldn't need to install any drivers for this to work.

    Perhaps the problem in your case is that you have some 3rd party software preventing XeThru device from being recognised as a standard USB CDC device?
  4. lynx

    lynx New Member

    Hi Bjørn, thanks for testing this. I figured out how to get it to work: I noticed that the sensor appeared in System Preferences -> Network as a modem. After removing this modem entry the Explorer successfully found the sensor.
  5. Bill Gatliff

    Bill Gatliff New Member

    Same problem here, and same solution: select System Preferences->Network, then the USB modem associated with the X2M200 (it's probably at the top of the list), click the minus '-' sign, and delete it.

    Make sure that when you delete it, you tell MacOS to not put it back on the list if the device reappears (I didn't save the exact prompt).
    Charlie Shao and Olav Liseth like this.